Recent Changes - Search:

edit SideBar

AuroraUserManual

As of 12/11/2017 this is a work in progress, find the updated PDF user manual at: http://www.nledshop.com/downloads/documents/nled-aurora-control-manual-v2e.pdf

And find the Aurora Command Sheet at: http://www.nledshop.com/downloads/documents/nled-aurora-control-command-sheet-v2c.pdf

NLED Aurora Control Software – v.2c

Copyright© 2017 Northern Lights Electronic Design, LLC

Various NLED controllers are compatible with the NLED Aurora Control software. The software is used to create a multitude of patterns and sequences on a computer then, upload them to the compatible controller for the device to run by itself, without a computer connection. The simple GUI makes it easy for anyone to create custom color sequences of any sort and upload them to the controller. Great for LED projects that requires custom color sequences. In addition to standalone sequences, it also supports Live Control, send packets over USB or serial to the device for direct control of the outputs. It supports single color, RGB, or RGBW LED configurations. Along with capabilities for pixel mapping and other advanced layout features.

THIS SOFTWARE IS BRAND NEW AND WE NEED FEEDBACK PLEASE CONTACT WITH ANY QUESTIONS, BUG REPORT, OR FEATURE REQUESTS. EVERYTHING HELPS.

This is meant to be used in conjunction with the NLED Aurora Flowchart that was included with this download.

Color Sequences: Are dynamic data sets that hold the colors, patterns, and effects that the software generates. Each is based on Sequence Mode(described below) and contains data specific for the Mode being created.

Sequence Modes: Each Sequence is based on a Sequence Mode

Fade: (or Ramp) Color channels fade evenly from value to value(frame to frame). Start values can be adjusted to start a color channel fading from an offset position. Each color channel has an individual value/color and are completely independent of other channels.

Gradient: Allows color sequences with gradient/fades/offsets to be created using very little memory space. It has options to offset the start values dynamically and quickly create great looking color sequences that don't take up much memory space. The sequence shares a single color for every color channel for each frame.

Instant: (or Solid) Color channels change instantly from value to value(frame to frame) at the selected speed. Each color channel has an individual value/color. It allows the Slide Up or Slide Down sub-modes.

Each slide type can be Single Color, RGB or RGBW Type Slide Up: Slides channel values up from one channel to the next, based on data type. Slide Down: Slides channel values down from one channel to the next, based on data type.

Technical: A Technical sequence is an advanced sequence mode that allows complete control and sequencing of the LEDs. Each channel and each frame(referred to as a cell) is fully customizable. Each cell has options to ramp/fade up or down with start and end colors, or stay a solid color, along with independent speed values with millisecond accuracy. This mode also allows a mixture of single, RGB, or RGBW LEDs to be controlled together with independent control of each.

MORE INFO TO COME AS IT BECOMES AVAILABLE - NOT IMPLEMENTED

P.O.V.(Persistence of Vision): Persistence of vision can utilize images or video files to create color sequences that can be played on flow toys such as staffs, poi, and wheels, or anything else that moves quickly. A POV color sequence will display the image or video used to create it when the pixels are moved through the air or rotated. This mode is really on suitable for pixel controllers but is available on all controllers.

P.O.V. Image Modes: There are 4 ways an image can be loaded, the mode is dependent on the physical LED positions relative to the controller, the order of the pixels, and expected function of the final project. Some experimentation may be needed to find the one that will work for your project. Note the “first pixel” would be the pixel closest to the controller in the strand. 1: First Pixel Is On The Left. Rows Are Displayed Top To Bottom 2: First Pixel Is Bottom Left. Columns Are Displayed Left To Right 3: First Pixel Is On The Right. Rows Are Displayed Top To Bottom. 4: First Pixel Is Top Left. Columns Are Displayed Left To Right.

P.O.V. Usage Mode: There is an optional setting that will place gaps or spaces between displayed POV frames. In normal mode, the pixels will form a solid streak, with the various frame color values displayed in the streak. A mode of 1mS to 16mS will place empty space between frames, the higher the value the larger the space. This will make it appear more of a grid of light dots, rather than rows of streaks. The mode value is 1 millisecond per, so a value of 8mS places an 8 millisecond space between each POV frame.

P.O.V. Video Mode: This advanced persistence of vision mode allows a video or movie file to be loaded into the software rather than a static image. Each frame of the video file is played like an image would be, but multiple video frames are played in sequence. Just as the video file would play normally, the LED controller will display it as a series of POV images when played. Video content should be prepared and sized for the exact amount of pixels it will be played back on. Videos should be as short as Video POVs can be quite large and consume a lot of storage memory. Allow the software time transcribe the video file when loaded.

Load File: A button to load the POV image or video file into the software. Supports all image file formats excluding GIF and possibly others. For video files it supports MOV, AVI, and others, very dependent on the codec if it is compatible. When a video file is loaded the “Enable POV Video Mode” checkbox will automatically check/highlight itself, video files require time to transcribe.


Figure 1

File Play: Loads a user created text file to use as the channel values. The file can be created manually, or dumped from other software, such as a DMX sequencing program, as long as it is properly formatted.

Format: Standard .TXT files, UTF-8 Each line is a Frame. If there are 3 lines, there will be 3 frames On each line, data values are comma(,) delimited. Data values should be 0 to 255 for 8-bit processors, and 0 - 65,535 for 16-bit processors(no commas!) Data values should be written as ASCII strings. IE “255” equals 255, and not any characters with an ID of 255. The amount of lines determines the amount of frames, the amount of data values per line determines the Channel Amount. Both values are automatically set by software when the file is loaded. Example files can be found in the 'assets' folder included with the software.

Linked: This sequence mode allows multiple other sequences to be chained or linked together. That is, it will play the first sequence on the list, then the next, and so on, then start back at the first sequence. The user can select to select when the next sequence starts using either iterations or a timer in seconds. The maximum timer or iteration value is 65,535 seconds which is about 1092 minutes. Note: -/+1% timing error is possible.

Click on the grey linked slot and it will highlight red, then select one of the Color Sequence Icons from the selection menu. Once selected it will close the menu and update the icon. Choose to either use iterations(loops of the sequence) or to use a timer(value in seconds) The Transition Types check boxes offer 4 options for transitioning from one sequence to the next. Either Fade(Ramp) with two speeds, Instant transition, or per sequence. Per sequence is set by the “Transition In” sequence option found the on the left sidebar under the “Sequ” tab. Use the + and - frame buttons near the bottom of the window to add additional linked slots. Use the side scroll bar to scroll through the currently available linked slots. Or use your mouse wheel.

Hardware Tab: All the configuration settings for the hardware/device can be found here, such as memory size firmware version, bootloader versions and additional device details.

Connecting to Hardware Devices: After starting the software with the device already powered and connected to the computer over USB, open the hardware tab and select the COM/Serial port the device was assigned. If the correct COM port is opened it will respond and the software will receive its device information and display it on the upper part of the hardware tab. It will then load the device configuration file based on the device connected and indicate it is connected by turning the “Connect” button green(from red) in the upper left corner.

Device Configurations: Once the device is loaded, the software will generate an option module for each of the configuration options. Using the device datasheet and your project requirements, select your configurations settings using the modules. When ready open the Connection Tab to upload or use the “Upload Configurations” button on the Hardware Tab.

Enter Bootloader: There is a button “Enter Bootloader Mode” that allows a command to put the controller into bootloader mode. Bootloader mode allows a new or updated firmware to be uploaded to the device over USB or serial(using a serial adapter). Please see device datasheet and www.NLEDshop.com/bootloader for details.

Open Device Webpage: Opens the www.NLEDshop.com webpage for the currently loaded device. Find firmware updates, datasheets, and more details for your device.

Upload Configurations: A shortcut to upload the configuration data to the device. See Connection tab section for details.

Request Configurations: Requests the connected device's configurations and will update the configuration option modules displayed on the Hardware tab. As of v.2d not yet implemented.

Software Tab: All the settings and information for the software are found here. Such as Load or Save sequence files, Sequence removal, Sequence Duplication, Sequence ID text string input, user channel amount, and window size options. Along with the options for the Graphic Layout Tab.

Window Size: NLED Aurora Control software is vector based and fully re-sizable, either grab the window edge and drag with your mouse or press either of the resolution size buttons on the Software tab. The software is mostly vector, so is re-sizable without any quality loss. Compatible from 480x360(WxH) and up, 4:3 resolution.

Default User Channel Amount: The software is compatible with many different devices with different capabilities. For Pixel Controllers, this option allows the user to set the default amount of channels they plan to use. Which means if your project has 100 RGB LEDs, you would set this option to 300(100 pixels times 3 for RGB). If you are using 100 RGBW pixels you would use 400(100 pixels times 3 for RGBW). This value is only used for the default value for making new sequences, the software uses a per sequence Channel Amount, meaning each sequence has an individual Channel Amount. The Channel Amount is separate but work in tandem with hardware specific features like Pixel Packet Cloning. Using a lower Channel Amount causes sequences to use less device memory and will allow more efficient stand-alone usage.

Some devices do not allow the Channel Amount to be altered, and will not allow any changes. Most non-pixel controllers are that type.

Color Sequence Editing: Clear Sequences: deletes all sequences from list. Duplicate Sequence: makes a copy of the sequence and adds it to the end of the list. Click the button first(it highlights) then click on the sequences you want to copy. Delete Sequence: removes a sequence from the list. Click button first then sequence to delete. Edit User ID Text: Edit the user ID string for a sequence, press the button first, then type in the new string, then click on the sequence you want to apply the change to. Press Return/Enter to apply.

Load/Save/Edit Sequences and Load Device File: Save Sequences: Save the current sequences and software settings to a file. Can be anywhere or have any name, but must remain a TXT file. Load Sequences: Load a sequence file from the computer. Clear Sequences: Deletes all color sequences currently loaded. Duplicate Sequence: Duplicates a color sequence, adding it to the last slot on the right side. Click the button then click the sequence icon, then click yes to the prompt to duplicate. Delete Sequence: Deletes a single color sequence. Click the button then click the sequence icon on the right to delete. Edit User ID Text: Edits the user text for a color sequence, the user text can be used to help manage and navigate your loaded color sequences. Click the button, then click the sequence icon the right, the textfiled will highlight red, then type in the new text. Press the “Enter” key to apply the change. Load Device File: If you want to create Sequences for a particular device, but don't have it connected to the computer, you can load the device's device file from the /devices folder. Once loaded you can create sequences as if the device was connected.

Graphic Layout Options: The dropdown has several shape options, the shape option will be used to arrange the LED icons on the Graphic Layout tab. Shape Dropdown: select a shape, custom, or image option. Once a shape is selected it automatically will display the selected shape on the Graphic Layout tab, the number of pixel icons is calculated based on sequence channel amount and color mode. Round, Square, Line shape options will position the LED icons to form the selected shape. Spiral will create an Archimedes spiral, the size of the LED icon will probably need to be reduced for this shape to work correctly. As it takes up a lot of space on the graphic layout tab. Pixel Map allows a patch/map file to be loaded and used for the LED icon positions. Currently the mapping software is available separately. The map data is saved along with the color sequence data in the save files. Manual allows the user to manually place icons using the mouse on the Graphic Layout tab. Once selecint Manual from the drop down on the Software tab, navigate to the Graphic Layout tab, then the “Icons” menu on the left side. From there select “Place Icons”, place your icons then click that button again to end the placement. Load File Button: if you chose a custom or image as your shape option you will need to load a patch file or image file. Selecting 'Image' as your shape and an image file is loaded, it will display the image on the Graphic Layout tab and clicking on the workspace will place an LED icon, very helpful for certain projects. If you selected Custom as your shape, you will need to load a patch file created by NLED Matrix Patcher software, which allows icons to be placed on a grid. Graphic Layout Image Options: Allows the user to load, resize, and place an image file into the Graphic Layout tab. Then use it as a template to place LED Icons or to just visualize the color sequences. Place Image: Opens the file browser for the user to select an image file on their computer. Remove Image: Unloads/Resets an images and settings. Resize Image: Changes to the Graphic Layout tab and enables image resizing, drag the handles. Reset Position: Resets the loaded image placement and sizing. Graphic Layout Options: Few technical options for creating graphic layouts. Advanced Layout Mode checkbox: An advanced mode that allows the user to create more advanced shapes and groups. Rather than automatically generating a shape based on the sequence channel amount and color mode, it allows the user to generate shapes with specific number of LEDs. It also allows the users to generate layout shapes for specific groups. Group Function ID: A feature for that only works with Advanced Layout mode. Allows the user to assign pixel icons to certain groups that can be painted and controlled independently from other groups. Pixel Icon Amount: Used when generating Advanced Layout shapes, selects how many pixel icons to generate. Add Layout to Group: While in Advanced Layout mode, once the user selects a shape, sets the Pixel Icon Amount, and the Group Function ID, this button is then clicked to add the pixel icons to the graphic layout tab. Merge Groups: Merges all the pixel icons from all groups to a single group, that group is selected with the Group Function ID field. Clear Group: Clears all the pixel icons from the group indicated by Group Function ID.

""Graphic Layout Tab:"" Using the Software Tab, the user can select a shape layout that matches their project to get a visual representation of the colors and patterns being created that will be displayed on the Graphic Layout tab.

Usage: After setting up the desired options on the Software Tab, the frame buttons on the bottom can be used to add or remove a frame, reset the Sequence, and change the Frame being displayed on the layout. Clicking any of the LED Icons will open the color picker to alter the color of that channel. Or on the left sidebar, there is a “Tools” tab, which displays the paint options. Either paint All the LEDs, paint a group of LEDs, or create and select form a palette of colors.

Note: As of v.2c, the pixel icons are colored differently. The color of the icon is the starting color for that color channel or pixel. If the user selects on the side-bar tools menu: Tools -> Show Color Values. It will toggle an outer color ring that indicates the color of the currently selected frame that color channel or pixel.

Note: Shown without “Show Start Colors” the Pixel Icons color is based on the starting value, even the the selected frame color in this example would be Red(Frame#1 is highlighed)


Graphic Layout Tab, displaying “Spiral” shape, with 170 pixels

The NLED Aurora Flowchart has additional information on selecting colors and using the tool functions.

Timeline Tab: Another way to view and make changes to the Color Sequence. Each Color Channel is displayed as a row, the rows are divided into Frames, indicated with the labeled buttons. Each frame of each color channel create a Cell that can be clicked to open the color picker.

Usage: Click on the blue Frame buttons above the previews to change the Frame or use the frame buttons along the bottom. When a Frame is selected, it's Frame Mode and other settings are shown on the left side of the screen. Clicking the Frame button again on the timeline will open the color picker and allow the color to be selected for that channel and frame. Use the Color All button the Graphic Layout Tab if needed.

Start Value Indicators: Each color channel row has a Triangle Start Value Indicator. They can be adjusted(by clicking and dragging) to alter the starting position for that color channel. Bad start values can mess up a Color Sequence, if bad start values are found, the triangle start value indicator will turn purple(from red) and at the top of the previews a notice will be in red that the start values are bad and need to be reset, regenerated, or adjusted manually.(by clicking and dragging) Only on the Timeline Tab can the start values be adjusted, but the Graphic Layout Tab will indicate the starting color with the outer color.


Timeline Tab, Displaying Same Sequence as previous Graphic Layout image

The NLED Aurora Flowchart has information on selecting colors and using the tool functions.

Connection Tab: This tab is used to interface with the device. It allows the user to setup their Sequence Index and upload various types of data to the controller. Such as color sequences, gamma table, stand-alone commands, live control mode and device configurations.

Sequence Index: Located on the right side, the Sequence Index is used to create a list of sequences the user wants to load onto a controller. The order they appear on the list is the order they can be selected on the device using features like a button or through Aurora commands. Click on the “Add Sequence” tile to open the list of available sequences for selection. Right click on the icon to remove a sequence from the index.The sane sequence can be on the list multiple times.

Hardware Preview: This feature allows a sequence to be quickly uploaded and viewed on your project/LEDs. Click the Hardware Preview tile to open the sequence selection menu, then select a sequence to upload to the controller and will start playing.

Live Control: USB Live Control allows the output channels to be controlled over a data(USB as emulated Serial or Serial adapters such as FTDI, or regular COM ports) connection. Data is sent in packets, with a byte for each output channel in 8-bit mode(0-255), or 2 bytes per channel in 16-bit mode(0-65,535), in 16-bit mode the MSB is first. There are two methods in the Aurora software, either with a slider for each channel or using the color picker for each color channel.

The protocol is simple and there is a demonstration software app available. Please see NLED Aurora command chart for details.

Stand-Alone Control: In addition to direct control of the outputs, the standalone sequences that are already uploaded to the controller can also be controlled through various means. Such as stepping, speed control, sequence selection. Please see NLED Aurora command chart for details.

Gamma Correction: Aurora compatible devices allow the optional use of a gamma correction or dot correction tables. The gamma correction values are applied to the final output values and affect channel intensity. Gamma correction is a complicated subject not covered here. There is an option to use a pre-defined table of values, or the user can create their own gamma correction file(see 'assets' folder for files and details), the tables are uploaded and stored on the controller. In order to utilize the gamma tables, the user must also select the Gamma Correciton enabled option in the Hardware Configurations.

Note: Some devices support gamma correction but do not use tables, so the user can not edit the gamma correction profile, see device datasheet for specifics. Contact if you require a special formula.

Upload Configurations: The configuration options that are selected on the Hardware Tab are uploaded to the device using this button. Such as DMX address, DMX Mode, baud rates, LED indicator function, etc.

Upload Sequences & Index: Uploads Sequence Index and all the indexed Sequences to the device. The Sequence Index must be created before uploading. All previous sequence data on the device will be erased, allow several seconds for this to complete. The progress will be displayed on the screen.

Global Intensity: When uploading a Hardware Preview sequence or a Full Upload with Index, there are a few options to adjust the final intensity or dimming value to the color sequences. The applied intensity adjustment affects the color sequences as they are sent to the controller, and once loaded to the controller the adjustment can not be altered. This is the fastest and most accurate way to apply a dimming value to color sequences. There is an option to use either the Global Intensity field, or override it and use Per Sequence intensity that is selected in the left-side tool bar. These options are independent from hardware device side dimming, through commands or buttons.

Left Side Tool Bar:

Sequ.(Sequence) Side Bar Menu: The primary place that the per sequence settings can be adjusted. Such as Sequence mode, Speed, Number of Channels(Channel Amount), Packet Cloning, Play modes, Transition modes. Sequence Mode(Drop Down): Selects the sequence mode, see first section for details on sequences. Pixel Data Type or Color Mode(Check Boxes): Single, RGB, or RGBW. Selects the per sequence type of pixel. Speed: Selects the speed the sequence plays. Each increment is equal to 1 millisecond on most devices. For Instants and similar, the Speed value is how long each frame is displayed on the pixels. For Fades(ramps) every iteration, the device will fade all color channels towards their next value. Fading/Ramping routine can take time on the device, depending on the amount of pixels and other settings, so lower values may not always be true to their speed value and will just run slower than specified. Intensity(Text Field): This is the Per Sequence intensity feature, when the sequence is uploaded to the device the software will apply this intensity adjustment, if the option is selected. See connection tab description for details. Num. Of Channels(Increment/Decrement Text Field): Selects the amount of channels the sequence will utilize, the number of channels is divided by the color mode(single, RGB, RGBW) and adjusted by options like Packet Cloning. Below under the “Extended Pixels” heading indicates how many Pixels with the current settings are utilized. Packet Clone(Drop Down): Some devices, mostly pixel controllers, allow the final output packet sent to the pixel strand to be duplicated, cloned, or otherwise sent more than once. This does not allow additional pixels to be controlled independently, but can allow a single longer strand of pixels to be controlled. Example: Strand of 100 pixels with clone value of 1, would make Pixel#1 and Pixel#101 act the same, Pixel#2 and Pixel#102 would act the same as well, etc down the strand to Pixel#200, which would act the same as Pixel#100. Changing the packet clone value will be indicated under the “Extended Pixels” heading below it. Transition In(Drop Down): On a per sequence basis the user can select a transition method that will be applied when the sequence starts(or Transition Into). There are a few options, more to be added in the future. Play Mode(Drop Down): Selects the play mode of the sequence, which includes things like Loop endlessly(most common), or play once(one-shot) with mode. One-Shot Next is play sequence once then start the next sequence on the index. One-Shot Start is play sequence once than stop/pause on the starting values. One-Shot End is play sequence once and stop/pause on the end values. One-Shot Blank is play sequence once and blank/turn off all the pixels. One-Shot Idle is play sequence once, then start the Idle Sequence.

Tools Side Bar Menu: Shows all the tool functions available to edit color sequences. Paint Tool: User selects a color by clicking the A, B,C,D icons. Then, when the Paint Tool button is highlighted(red, click to highlight) the user can click on pixel icons to apply the color to that icon and color channel. This can only be done from the Graphic Layout Tab. Paint Multiple, All and Group: Allows the user to paint multiple Pixel Icons or Color Channels at once, either All at once, or on a per group basis. The group ID that is affected is indicated by the “Group View” tool on the bottom right corner. Show/Hide Color Values: Toggles viewing the selected frame color values around the Pixel Icons on the Graphic Layout tab. Reset Values: Resets the start values to their default values. Radial Tool: Only used on the Graphic Layout tab, this tool alters the start values. But it does it based on the location of the Pixel Icons, which would indicate their positions on the project. This does it in a radial method, use the mouse to select the center point, then move away to center to indicate the distance to apply the effect. This is used in conjunction with Multiplier text field. Linear Tool: Another start value tool similar to Radial Tool but affects the start values in a single linear direction. Multiplier: Used with the Radial and Linear Tools, a higher value applies a greater effect to the tool usages. Value can be comparable to Gradient Steps below, except higher Multiplier values have a greater effect. Gradient Steps: A start value function that applies linear offset start values to all color channels. Basically offsets the starting color values across the color sequence. An example R->G->B color sequence can be made a seamless rainbow(first to last pixel) with a Gradient Step value equal to the amount of Pixels. Select the amount of Gradient Steps, which can be a positive for forwards, or a negative number for reverse, then click the Generate button. The start value indicators(upside down triangles) indicate the starting value, and this feature is best explained by testing it out in software.

Frame Side Bar Menu: Per frame options are displayed here, not many options and are Sequence Mode specific. Copy: Copies the entire selected frame to scratch. Paste: Pastes a copied frame to the currently selected frame. Cell Speed: Used with Technical Sequence modes, indicates time in milliseconds. Frame Mode: Used with Technical and Instants. Can be used to indicate per frame sequence modes. Slide Options, Slide Value: Special input for Instant Slide Frames. Indicates the number of slides to perform. Per Frame Color Mode: Indicates whether the per frame function is single, RGB, or RGB color data type.

Icons Side Bar Menu: Per frame options are displayed here, not many options and are Sequence Mode specific. Enable Group Assignment: When clicked and highlighed, clicking on a pixel icon will place that icon in the group indicated by Assigned Group ID field. Advanced Layout checkbox must be enabled on the Software tab. Assigned Group ID: Selects what Group ID number the to use when applying Group Assignment. Icon Placement, Place Icons: If the shape layout on the software tab is set to “Manual” or Advanced Layout is enabled, selecting this button then clicking on the Graphic Layout workspace will place a pixel icon for use in the layout. Every click will place a pixel icon. Icon Placement, Remove Icons: After selecting this option, clicking on pixel icons located on the Graphic Layout workspace will remove that icon from the list. If you were then to Place Icons again, it will fill any pixel icons that are were removed first, before placing icons with new IDs. Icon Placement, Reset Icons: Clicking this will remove all the pixel icons.

Feature Specifics

Aurora Command Protocol: Aurora compatible controllers have a specialized command set that is used to control and command the controller from the Aurora software or from user created software applications. It is a simple character exchange protocol based on ASCII and 8-bit numbers. Many NLED controllers have USB compatibility, the USB drivers make it appear as a standard legacy serial or COM port to computer. Other controllers may require a USB to Serial Adapter(such an FTDI) or other form of TTL(5 volt) serial converter in order to interface with the NLED controller. Some NLED controllers can use TTL serial and USB interchangeably and transparently to computer side software. The feature is listed as “Dual Command Mode” and must be selected through hardware configurations, it may interfere with other data communication methods such as DMX or Serial, see device datasheet. Whether the device is connected over USB or serial, the command protocol works the same and is transparent to the controller and software.

Any software language that can communicate with serial ports can interface with Aurora controllers. The command protocol is also so simple that commands can be issued from a serial terminal like RealTerm or HyperTerm.

Details and specifics can be found in the “NLED-Aurora-Control-Command-Sheet-vXX.pdf”

And an example software application can be found separately.

Communication Hierarchy: A hardware device may have multiple communication methods, such as USB, DMX, serial, IRDA, etc. While many run concurrently(USB always runs if enabled) the other ones may share hardware or in/out connectors. So depending on user configuration settings some features may not be accessible.

Dual Command mode will disable all DMX in(reception) and out(master) communications, and alos disables serial mode data reception. Serial mode is different from serial input that Dual Command mode uses.

Master DMX mode will disable all DMX reception and serial mode reception.

If neither DMX master or Dual Command mode is set, then the autodetect(DMX or serial) feature can be enabled. Nothing will stop the user from setting, as an example, DMX master mode and autodetect DMX, but since DMX master is enabled the device will not be able to receive and autodetect DMX data.

Dimming / Intensity Options: There are a few different ways NLED controllers allow the user to control the overall output intensities, this can be applied to stand-alone sequences or data reception methods(DMX, Serial, USB).

Software Side: As described earlier in this manual, the software has two options to apply an intensity value to the stand-alone sequences. Any intensity options offered in software are applied to the stand-alone sequences during uploading to the controller. The software alters the sent data values to reflect the user's intensity settings, it does not affect the sequence data stored on the computer, only what is uploaded to the device. These intensity values can not be changed on the device the sequences would have to be re-uploaded. Offered as a global or on a per sequence basis.

Device Side: The controller also has options to adjust the output intensities of the outputs. Most controllers allow fine control(high resolution or steps) of the intensity. But some devices do not have fine control, and may only have 4 intensities(12.5%,25%,50%,100%). All device side intensity/dimming allows on-the-fly(immediatly used application of the user indicated intensity. The intensity is used with stand-alone sequences, but may also be applied to data communication modes such as DMX, serial or USB. See datasheet or Contact Support for specifics.

Notes: Maximum Frames: 65,535 - May vary based on sequence mode and platform Maximum Stand-Alone Channels: 512 Maximum Data Control Channels: Varies with controller Maximum Index Sequences: 256 Maximum Sequences In Software: 256

When changing sequence modes, data from mode to mode may persist(on purpose) That allows the user to do more advanced uses like load a File Play type, and switch to Fade mode and utilize the File Play data.

Hot Keys: s: Quick save, creates a save file using the time and date as the file name. m: send dummy command to test if connected/alive. Escape: Close the software. Left and Right Arrows: - Adjust previously selected slider Enter/Return: - If text field is selected it commits the change - If color picker is open it applies the color selection - While resizing Graphic Layout Image - Press Enter/Return to apply - Closes Technical mode radial menu

Right Click on an Indexed Sequence Icon to Remove Left Click on a LED Icon or timeline button to open the color picker Mouse wheel over the timeline, index, color sequence index(right side) to scroll the view slider.

Glossary of Definitions:

Color Sequence: or just Sequence. A color pattern, contains all the data to control the LEDs. Or dataset(how the color data is stored) that creates colors, patterns, and sequences. Can be single color, RGB or RGBW, all are still color sequences.

Channels: A channel represents a single output on a controller or a single color of a pixel. An RGB pixel uses 3 channels, an RGBW pixel uses 4 channels.

Color Channel: Represents a single LED or pixel. That could be either single color, RGB, or RGBW(or RGB+U.V.) A Color Channel is seen as 1 or more Channels. A sequence set to RGB Pixel Data Type will use 3 Channels Color Channel. A LED Icon(on the Graphic Layout tab) or a row on the Timeline tab represent a Color Channel.

Pixels: May be used interchangeable with Color Channels, indicates a single pixel(of any color mode), but may also refer to group of output channels.

Frame: The data stored in each Frame will be displayed on the outputs/pixels sequentially. A Frame can be thought of as a single frame of a video, it holds all the data to create those colors. The next frame will hold new colors. For fades, gradients, and combos, the start value can be adjusted to start different output channels in different frames, creating multicolor sequences with less creation effort and data space.

DMX Reception: Receive and utilize a DMX-512 signal

Serial Reception: Receive and utilize a standard 8-N-1 serial signal. At the user selectable baud rate.

Index: Contains a directory, list, or order of the color sequences that will be uploaded to the controller.

Pixel Data Type or Color Mode: Indicates to the software and controller the LEDs that will be controlled are either a single color LED(like just blue), RGB, or RGBW(Any 4 colors)

Pixel Icons: Shown on the Graphic Layout tab in the workspace. They indicate a pixel or color channel that can be edited. Pixel Icons are the same as a row on the Timeline tab. But the user must manually select the frame using the buttons at the bottom of the workspace.

Project: Refers to the user's project and the LEDs that are used in it. Everybody's projects will be different, different layout of LEDs, different quantities of LEDs, different usages, different types of LEDs(single color, RGB, RGBW), and all sorts of other variations.

Group: The software allows multiple LEDs in any order to be grouped together. Once grouped they can be viewed and acted/altered upon on per group basis.

Power Cycle: Removing all power supply from the controller. Including USB and any power ran to the LEDs or pixels. To prevent USB lockup, disconnect software from the device before power cycling.

Datasheet: or Device Datasheet, each hardware device has a document that describes its features and their usages.

Pixel Patch or Pixel Map: Defines to the software the physical positions and order(1st pixel, 2nd pixel, 3rd pixel etc) of the LEDs/Pixels.

Device: Refers to the hardware platform or controller.

Packet Cloning: For pixel controllers only, repeats the same pixel data in one packet, making longer strands of pixels.

Edit - History - Print - Recent Changes - Search
Page last modified on December 11, 2017, at 02:01 PM